Upgrading headlamps to LED bulbs sounds great but can pose problems | Forum

Topic location: Forum home » General » General Chat
freemexy
freemexy Sep 3

Upgrading headlamps to LED bulbs sounds great but can pose problems Let’s look at your dim bulb first. Incandescent bulbs typically emit about the same amount of light until the moment they burn out, so renewing the bulb isn’t likely to help. What’s more likely is a fault in the circuit leading to the headlamp.To get more news about led headlight kits, you can visit iengniek official website.

With luck, perhaps there’s a loose or corroded connection at the headlamp electrical connector. Accessing the connector will require removing the headlamp housing, which is pretty easy to do. With the hood up, after removing a pin type retainer, the radiator side air deflector can be folded back a bit, allowing access to all three headlamp housing retaining screws. The housing can then be pulled forward, allowing bulb/connector inspection or replacement.

It’s easiest to inspect/test the connectors by removing both high and low beam bulbs from the housing and setting the housing aside. A slight twist counter clockwise ([ turn) will disengage the bulbs. You didn’t mention if it was just the low beam that is dim, or perhaps both low and high beams. There are three wires in each headlamp connector. If it’s just the low beam that’s dim, the blue/green wire circuit connected to the headlamp isn’t doing its job. If both high and low are affected, this should be easy; the black/grey wire leads to a possibly loose/corroded ground connection (G-101), the wire screws to the radiator core support right behind the headlamp housing. Try also wiggling/inspecting the headlamp connector; if headlamp performance improves, a bad connection exists there.

Look also for corroded or overheated terminals. Unplugging and reconnecting will clean the terminal connection slightly. If the connector terminals are in bad shape, connector replacement will be needed (wires are cut and spliced). If it’s just the low beam that’s dim and the connector looks OK, the fault may lie in the body control module (the source of power for the low beams). Testing there for output voltage is likely a pro level job, this would confirm if its the BCM that’s faulty or possibly an issue with the blue/green wire. I’d tread carefully if considering aftermarket/inexpensive headlamp housings. They are notorious for poor optics/glare. Look for good reviews and a generous return policy? Upgrading to LED bulbs sounds great but can pose problems as well. The placement of the light emitted may not match the original bulb, again causing glare/alignment issues. I tried a set of these a few years back and they were exquisitely bright, so much so that I had to remove them due to antagonizing oncoming drivers.